Fatal Error in VirtualBox

I just installed Virtual box a few days ago to run Windows inside Ubuntu. But after messing with group permission and upgrades, there was an error similar to the one below.

Could not load the settings file ‘/home/MyUsername/.VirtualBox/OpenSUSE 10.3.xml’ (VERR_OPEN_FAILED).

FATAL ERROR: Unknown element ‘PXEDebug’

Whatever it was, I kept getting it after multiple removals and reinstallations. Ubuntu forum did not have a solution, or at least not the one that worked for me. So, I decided to come up with a solution myself and it was incredibly simple. The goal is to remove the .xml file and then reinstall VirtualBox.

Solution

  1. Entering Synaptic.
  2. Search for “virtualbox” and uninstall all VirtualBox packages.
  3. Then open your home folder,
  4. On the menu bar, select View -> Show hidden files and folder.
  5. Delete the folder called “.VirtualBox“. This will erase the annoying .xml file.
  6. Reinstall VirtualBox like usual. For instruction on how to install, visit Ubuntu community.

Worked like a charm. Try it out. Cheers.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: