Hardy and GeForce 7200

Note: Geforce and Hardy now work on my computer perfectly. See this post. All I did was downgrade to 7.10 and then upgrade back into 8.04. And everything was fine. I assume that the new upgrade has something to do with it. But no guarantee.

I finally upgraded to Hardy, thinking that it was finally my time to catch up to the rest of the world. As I suspected, the new driver for my GeForce 7200 did not work at all. After the installation and a reboot, no graphic card was detected and my display went back to low resolution. I was ticked off big time since I’m one of those people paying attention to details and appearance. This is almost as upsetting as the time when I found out about the memory leak problem with Compiz on nVIDIA graphic card.

There was no solution for this issue that worked for me. So I decided to uninstall the new driver package and to stick to 2D display, which was not too bad at all. The only loss is that I would not be able to run Compiz, which was already problematic by itself. Oh, there are many other “pretty” software that require 3D acceleration. But I guess I can live without them… Maybe.

Sorry that I failed to provide a solution and I did nothing but to whine about it. If you do get problems after installing the new driver, I offer a solution to roll back in Hardy. It’s 1 am. in the morning so there won’t be much graphic here because I’m too tired to edit those snapshots. Now, since I am not sure what is really going on, I can’t guarantee that my solution will work on all Ubuntu machines.

Problem: Install the new NVIDIA driver in Hardy – package nvidia-glx-new – but after reboot there was an error announces that no graphic card was detected and the display goes back to low resolution. The error persists after enabling the driver and reboot. Below is how to roll back.

Rollback

  1. Enter Synaptic: System -> Administration -> Synaptic Package Manager.
  2. Hit Ctrl+F to search or click on the binocular icon. Search for glx.
  3. Remove nvidia-glx and nvdia-glx-new by clicking on them and select “Mark for complete removal.” Note that this means you will not have any 3D acceleration at all.
  4. Restart the computer.
  5. Enter Recovery mode when Grub starts. This mode in Hardy will provide some basic options.
  6. Select Repair packages and then Repair X sever. I’m not sure why but it worked.
  7. Hit Esc or select Resume to boot back into Ubuntu.
  8. Everything should look fine now.

Well, I can live without 3D acceleration. How about you?

Advertisements

4 Responses

  1. Thanks. It helps me in solving my problems. The same as you, I lost the 3D capability.

  2. Thanks for commenting Neotorture.

  3. Search for envyng using synaptic package manager. If running Ubuntu you will need envyng-gtk, for Kubuntu use envyng-qt.
    Envy will install the 173.14.09 nvidia driver.

    Can’t be certain that this will fix your issues but worth a try imo.

  4. Thank you Fungyo, but I tried EnvyNG already, did not work. I get the same result as soon as I enable the driver.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: